NPM — менеджер пакетов для модулей nodejs.

Он используется для установки, обновления и удаления пакетов из приложения nodejs.

В этом руководстве вы узнаете, как найти установленную версию пакета модулей в вашей системе.

Вы можете использовать команду npm list для поиска локальных пакетов и npm list -a для глобально установленных пакетов.

npm list                
npm list -g

Как найти конкретную версию пакета

Вы можете найти версию определенного пакета, передав его имя в качестве аргумента.

Например, выполнение npm list приведет к выводу:

npm list oauth

`-- oauth@0.9.15

Как найти все версии пакетов

Кроме того, вы можете просто запустить npm list без передачи имени пакета в качестве аргумента, чтобы увидеть версии всех пакетов, установленных в вашем текущем проекте.

Используйте -g, чтобы найти глобально установленные пакеты.

npm list
| +-- glob-parent@5.1.0
| | `-- is-glob@4.0.1
| +-- globals@12.3.0
| | `-- type-fest@0.8.1
| +-- ignore@4.0.6
| +-- import-fresh@3.2.1
| | +-- parent-module@1.0.1
| | | `-- callsites@3.1.0
| | `-- resolve-from@4.0.0
| +-- imurmurhash@0.1.4
| +-- inquirer@7.0.4
| | +-- ansi-escapes@4.3.0

В приведенном выше списке показаны все установленные пакеты, включая их зависимости.

Вы также можете добавить аргумент —depth=0, чтобы вывести список установленных пакетов без их зависимостей.

npm list --depth=0

Как найти пакеты, которые требуют обновлений

Чтобы узнать, какие пакеты необходимо обновить, вы можете использовать команду npm outdated, чтобы вывести список всех пакетов, установленных в более старых версиях.

npm outdated --depth=0             
npm outdated -g --depth=0

 

Поделитесь статьей:

Добавить комментарий